Activations and plan changes may be delayed.
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 22:20 EST
Identified
We are working through a large number of items, activations and plan changes are taking longer than normal
Posted Nov 20, 2023 - 19:34 EST
This incident affected: Iridium Activation and Subscription Billing.