inReach and Explore Outage

Incident Report for Garmin Services

Resolved

All inReach and Explore related systems are operational.
Posted Jul 27, 2020 - 11:07 EDT

Update

Update - The Explore site and Explore app sign in are now working. Some features may not be fully available or work intermittently, such as syncing data between the web site and app. The Explore site map is available.

inReach billing (service activation and plan changes) is still unavailable.

inReach SOS and messaging continue to work.
Posted Jul 27, 2020 - 00:18 EDT

Update

Update: Garmin Sign In is currently unavailable, which affects both the Explore site and Explore app.
Posted Jul 26, 2020 - 19:13 EDT

Update

The Explore site and Explore app sign in are now working. Some features may not be fully available or work intermittently, such as syncing data between the web site and app. The Explore site map is available.

inReach billing (service activation and plan changes) is still unavailable.

inReach SOS and messaging continue to work.
Posted Jul 23, 2020 - 22:38 EDT

Update

NOTE: inReach SOS and messaging have been fully functional and remain so. This includes the MapShare web site and email reply page.
Posted Jul 23, 2020 - 11:38 EDT

Update

Garmin Sign In is also unavailable, so there is currently no access to the Explore app, the Explore web site, and inReach sync desktop app. MapShare is still available.
Posted Jul 23, 2020 - 09:49 EDT

Investigating

We are currently experiencing an outage that affects Garmin inReach and Explore, and as a result, inReach billing (credit card editing, service plan changes, and new service activation) is unavailable. However, inReach messaging (text, email and SOS) is fully functional. This outage also affects our call centers, and we are currently unable to receive any calls, emails or online chats. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.
Posted Jul 23, 2020 - 09:14 EDT
This incident affected: Satellite Activation and Subscription Billing and Garmin Explore Website and MapShare.