Subscription activation, plan switch and deactivation delays
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Oct 01, 2023 - 08:57 EDT
Monitoring
Since 3:38 AM Eastern US (7:38 UTC), subscription activation, plan switch and deactivations have been delayed.

The queued jobs started processing at 4:58am Eastern US (8:58 UTC) when services were restored.
Posted Oct 01, 2023 - 05:33 EDT
This incident affected: Iridium Activation and Subscription Billing.