Iridium Device Activations and Plan Changes Delayed

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 22:09 EDT

Monitoring

Iridium device activations, plan changes, and cancellations submitted between approximately 8pm EST (12am UTC) and 9:15pm EST (1:15am UTC) are currently experiencing a delay in processing. New activation, plan change, or cancellation requests are processing successfully.
Posted Aug 24, 2025 - 21:29 EDT
This incident affected: Iridium Activation and Subscription Billing.