Satellite Provider Maintenance

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 20:22 EDT

Monitoring

We are continuing to monitor the process.
Posted Jun 24, 2025 - 18:21 EDT

Investigating

Length of Time: 7.5 hours
June 24th 10:30 AM ET (14:30 UTC) to 7:30 PM ET (22:00 UTC)

During this vendor maintenance window, all satellite activations, plan changes, and deactivation will be delayed. We recommend waiting until after this maintenance is completed to make changes your account.
Posted Jun 24, 2025 - 18:20 EDT
This incident affected: Iridium Activation and Subscription Billing.