User Editing Issue
Incident Report for Garmin inReach
Resolved
Resolved
Posted 3 months ago. Apr 10, 2019 - 18:41 EDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 10, 2019 - 18:40 EDT
Investigating
Some customers are unable to create new users or modify their address book
Posted 3 months ago. Apr 10, 2019 - 16:31 EDT
This incident affected: Garmin Explore Website and MapShare.