Garmin Explore Website Unavailable

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 18:18 EDT

Identified

Some customers may experience issues accessing the Explore website. These issues do not impact device messaging or SOS functionality. The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 16:33 EDT
This incident affected: Garmin Explore Website and MapShare.