SMS Messages to some Australian customers may be delayed
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 21:36 EST
Update
We are continuing to investigate this issue.
Posted Nov 21, 2023 - 21:35 EST
Investigating
We are currently investigating this issue.
Posted Nov 21, 2023 - 20:23 EST
This incident affected: SMS/Text Communication.