inReach Service Activation and Plan Change Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 08, 2019 - 14:22 EST
Investigating
inReach service activation and plan changes are experiencing an outage, which began around 1:30 PM Eastern US time (18:30 GMT). We are investigating and will provide updates.
Posted 3 months ago. Mar 08, 2019 - 14:05 EST
This incident affected: inReach Service Activation and Billing.