SMS messages are not being delivered to Mexico phone numbers
Incident Report for Garmin inReach
Resolved
SMS messaging was restored to Mexico phone providers yesterday and we have confirmed through testing.
Posted Apr 14, 2021 - 13:40 EDT
Investigating
Since at least March 31st, some amount of inReach messages sent to the SMS numbers of phones in Mexico have not been delivered. We are working with our SMS provider for Mexico to determine the issue and get it resolved.
Posted Apr 12, 2021 - 11:55 EDT
This incident affected: SMS/Text Communication.