Delays with subscriptions activations, deactivations and plan changes
Incident Report for Garmin inReach
Resolved
The delays have been resolved. Further investigation revealed that the subscriptions activations, deactivations, and plan changes themselves were being processed successfully, but any notifications and the status of those actions in Garmin mobile apps and websites were delayed.
Posted Mar 08, 2024 - 09:57 EST
Investigating
We are currently investigating this issue.
Posted Mar 08, 2024 - 05:49 EST
This incident affected: LTE Activation and Subscription Billing.