Australasian data sync delay
Incident Report for Garmin inReach
Resolved
The issue has been resolved
Posted Jan 13, 2021 - 10:00 EST
Investigating
Some Australasian inReach customers may be experiencing a delay in syncing data such as contacts and preset messages.
Posted Jan 13, 2021 - 06:45 EST
This incident affected: Garmin Explore Website and MapShare.