inReach activation and deactivation outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved. All queued jobs were processed by 10:29 AM UTC.
Posted Sep 30, 2022 - 07:06 EDT
Identified
inReach activation, deactivation and plan change outage.

Since about 4:08 AM UTC, inReach service activation, deactivations and plan changes have been delayed.  These will process when services are restored.
Posted Sep 30, 2022 - 04:11 EDT
This incident affected: Iridium Activation and Subscription Billing.