Messages Delayed for some Customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Dec 14, 2025 - 07:54 EST

Update

We are continuing to investigate this issue.
Posted Dec 14, 2025 - 07:53 EST

Investigating

Messaging is delayed for some customers. SOS Communication is not affected. The issue has been identified and teams are working to mitigate / resolve
Posted Dec 14, 2025 - 06:20 EST
This incident affected: inReach Messaging.