Delays possible in activations, deactivations and switching active device on plan
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted May 16, 2023 - 21:26 EDT
Investigating
Since about 3:44PM Eastern US (19:44 UTC) there have been some delays in activations, deactivations and switching the active device on a plan for customers in the Americas. These queued jobs will process when services are restored.
Posted May 16, 2023 - 19:18 EDT
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.