inReach activations and service plan changes may be delayed
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 21:15 EDT
Investigating
New inReach activations, service plan changes, and service deactivations are processing slowly. These changes are being queued and will complete on their own without additional interactions from end users. The delay started at approximately 4:45 PM EST (8:45 PM GMT) on June 2nd.
Posted Jun 02, 2021 - 18:03 EDT
This incident affected: Iridium Activation and Subscription Billing.