Explore Website, Degraded Performance
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 18:05 EDT
Identified
Some customers may experience issues with loading and logging into the Explore web site. We have identified the issue and are seeking a fix.
Posted Jul 27, 2023 - 17:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2023 - 12:58 EDT
Investigating
Some customers may experience issues with loading and logging into the Explore web site. We are currently investigating the issue.

These issues do not impact device messaging, tracking or SOS functionality.
Posted Jul 27, 2023 - 10:29 EDT
This incident affected: Garmin Explore Website and MapShare.