inReach web site is unavailable
Incident Report for Garmin inReach
Resolved
inReach web site is now available
Posted Apr 09, 2018 - 18:06 EDT
Investigating
The inReach web site became unavailable about 20 minutes ago. We expect to have this resolved shortly. Updates will be provided.
Posted Apr 09, 2018 - 17:23 EDT
This incident affected: Garmin Explore Website and MapShare.