Activations and plan changes may be delayed.
Incident Report for Garmin inReach
Resolved
The incident has been resolved
Posted Aug 02, 2023 - 18:26 EDT
Investigating
One of our partners is having intermittent issues responding to our requests. These issues have the potential to delay activations and plan changes.

We are working with our partner to resolve the issue as quickly as possible.
Posted Aug 02, 2023 - 17:45 EDT
This incident affected: Iridium Activation and Subscription Billing.