The inReach website is currently unavailable and messaging may be delayed
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 27, 2018 - 11:31 EDT
Identified
The Explore and MapShare sites are fixed. Messaging is still delayed and being worked on.
Posted 11 months ago. Aug 27, 2018 - 10:45 EDT
Investigating
We are investigating an outage with the inReach website. This outage includes MapShare and any new inReach service activation or billing changes. SMS and email communication may experience some delays.
Posted 11 months ago. Aug 27, 2018 - 10:25 EDT
This incident affected: Garmin Explore Website and MapShare, SMS/Text Communication, Email Communication, and inReach Service Activation and Billing.