inReach weather forecasts are unavailable
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 28, 2019 - 11:24 EST
Investigating
Following scheduled maintenance, inReach weather forecasts are unavailable. We are investigating and updates will be provided.
Posted Nov 28, 2019 - 04:29 EST
This incident affected: Email Communication.