inReach and LTE activation and plan change outage
Incident Report for Garmin inReach
Resolved
The incident has been resolved. All queued jobs have been processed.
Posted May 20, 2022 - 09:22 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 09:19 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 20, 2022 - 09:18 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 20, 2022 - 08:53 EDT
Identified
inReach and LTE activation and plan change outage

Since about 7:30AM EDT US time, inReach and LTE subscription service activation and plan changes have been delayed. We recommend waiting until the outage is resolved before making any service or plan changes.
Posted May 20, 2022 - 08:49 EDT
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.