Explore and MapShare web sites loading very slowly for some customers
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 27, 2019 - 17:11 EST
Investigating
This issue began around 3:30 PM Eastern US time. We are investigating the issue and will provide updates.
Posted 7 months ago. Feb 27, 2019 - 16:18 EST
This incident affected: Garmin Explore Website and MapShare.