Subscription Activation and Plan Changes Delayed

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 16:37 EDT

Investigating

Subscription activation, plan change, and cancelation requests are currently delayed. Any pending actions will complete once the issue is resolved. We recommend waiting to activate or make changes to subscriptions until this issue is resolved.
Posted Aug 25, 2025 - 16:07 EDT
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.