inReach/Iridium messaging traffic being sent to a device may be delayed.
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 20:15 EDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2023 - 16:30 EDT