Subscription activation, plan switch and deactivation delays
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Sep 30, 2023 - 12:25 EDT
Monitoring
Since 4:00 AM Eastern US (8:00 UTC), subscription activation, plan switch and deactivations have been delayed.

The queued jobs started processing at 7:10am Eastern US (11:10 UTC) when services were restored.
Posted Sep 30, 2023 - 07:23 EDT
This incident affected: Iridium Activation and Subscription Billing.