Explore Website, Degraded Performance / Unavailable
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jul 31, 2023 - 17:02 EDT
Investigating
Some customers may experience issues with loading and logging into the Explore web site. We are currently investigating the issue. These issues do not impact device messaging, tracking or SOS functionality.
Posted Jul 31, 2023 - 16:08 EDT
This incident affected: Garmin Explore Website and MapShare.